What operating systems support the eGPU? What are the minimum operating system requirements?

OS X:

  • OS X Yosemite 10.10.3 or later (only GTX 9xx and Titan X (Maxwell) graphics cards)
  • OS X El Capitan 10.11 or later (only GTX 9xx and Titan X (Maxwell) graphics cards)
  • macOS Sierra 10.12
  • macOS High Sierra 10.13*
  • macOS Mojave 10.14 Only AMD eGPUs are supported until Nvidia releases a new driver for macOS Mojave

Note: Sleep mode and FileVault are not supported.

Note: Nvidia GTX 10xx (Pascal) graphics cards are supported only on macOS 10.12.4 and later.

Note: Nvidia GTX 20xx (Turing) graphics cards will be supported on macOS Mojave once Nvidia will release a new driver.

Note: AMD Polaris graphics cards are supported only on macOS 10.12.6 and later.

 

Windows (Boot Camp):

  • Windows 8.1
  • Windows 10
Have more questions? Submit a request

Comments

0 comments

Article is closed for comments.